Friday, December 31, 2010

NETWORK CLASSES

Network classes

Class Leading bit Decimal range Max networks Max host

A 0 1 - 127 127 16,777,214
B 10 128 - 191 16,384 65,534
C 110 192 - 223 2,097,152 254
D 111 224 - 239
E 1111 240 - 255

Monday, December 20, 2010

Transport Layer

Transport Layer
Purpose of Transport Layer
Tracks Individual Communications
Segments and manages each piece of data
Reassembles the data
Identifies the different applications

Applications do not need to know the operational details of the network.

The Transport layer keeps track of what data goes where, and from what application by using port numbers.

The transport layer helps with segmenting and multiplexing.

All transport layer protocols handle
Segmentation and Reassemble
Conversation Multiplexing: Many applications on each host in the network

Each Application is assigned an address known as a port.
Well Known Ports
22 SSH
23 Telnet
25 SMTP
53 DNS
80 HTTP
69 TFTP
67 DHCP

Sunday, December 19, 2010

Well known ports

Well Known Ports
22 SSH
23 Telnet
25 SMTP
53 DNS
80 HTTP
69 TFTP
67 DHCP

Wednesday, November 17, 2010

EIGRP

Enhanced Interior Gateway Routing Protocol (EIGRP) is an enhanced version of IGRP. IGRP is Cisco's Interior Gateway Routing Protocol used in TCP/IP and OSI internets. It is regarded as an interior gateway protocol (IGP) but has also been used extensively as an exterior gateway protocol for inter-domain routing.

Twisted Pair cable

Unshielded Twisted Pair cables help reduce interference.This happens because of the twisting of the wires in the cable and the magnetic field around the adjacent pairs of wire.

Sunday, November 7, 2010

Static Route

hostname R2
!
enable password ww
!
!
!
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
!
!
interface Ethernet0
description Local LAN
ip address 172.31.10.2 255.255.255.0
!
interface Serial0
description Primary Link to R1
ip address 10.10.10.2 255.255.255.252
clockrate 56000
!
interface Serial1
description Backup Link to R1
ip address 192.168.20.2 255.255.255.252
!
interface TokenRing0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1

!--- This is the primary default route.

ip route 0.0.0.0 0.0.0.0 192.168.20.1 250

!--- The floating default route to be used if the T1 fails.

no ip http server
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password ww
login
OSI Model

Application
Presentation
Session
Transport
Network
Data Link
Physical

TCP/IP Model

OSI MODEL

Subnet Calculator

My favorite Subnet Calculator
http://www.subnet-calculator.com/